Back to overview
Degraded
Shopify Cloud Degraded Performance
Jun 3, 2026 at 1:52pm UTC
Affected services
Main Store
Mobile App
Shopify Cloud Service
Resolved
Jun 3, 2026 at 2:56pm UTC
Issue resolved, Shopify Cloud is back online again.
Affected services
Created
Jun 3, 2026 at 1:52pm UTC
Admin, storefronts, and checkouts are impacted.
Affected services